GeoHot: Baseband 05.11 Can’t Be Unlocked At The Moment

GeoHot is back, and he is telling us that there is no unlock for baseband 05.11 yet because, there’s no exploits at the moment for the new baseband.

GeoHot is back, and he is telling us that there is no unlock for baseband 05.11 yet because, there’s no exploits at the moment for the new baseband.

geohot_iPhone_baseband_05.11

The baseband is native for the iPhone 3G and 3Gs, and also for firmware 3.1 and higher and without an exploit, people depending on unlocking tools, will not be able to make/receive calls.

There is no date on where the new tools might hit the market but both, the iPhone DevTeam and GeoHot, are working to resolve this issue. Until the we have the new tools, keep away from restoring with an official firmware.